Bluebeam Revuで「ドキュメントを発行できませんでした。オブジェクト参照がオブジェクト インスタンスに設定されていません。」とエラー表示されファイル保存ができない場合があります。
■問題
特定のファイルまたはファイルのグループで次の問題が発生します。
- 「オブジェクト参照がオブジェクトのインスタンスに設定されていません。」というエラーメッセージが表示されます。
- 特定のマークアップ/ツールは特定のPDFでは機能しません。
■原因
ファイルの1つ、またはファイルのグループが破損している可能性があります。ファイル破損の一般的な原因は次のとおりです。
- PDF変換によるもの。特定のPDFコンバーターは低品質のPDFを生成する場合があります。
- PDFのアップロードまたは保存。別のシステムプロセスがPDFの保存またはアップロードを中断すると、ファイルが破損する可能性があります。
■解決
「PDFの再作成」は、ファイル固有の破損の問題を修正するための方法です。
PDFを再作成するには:
- 影響を受けるPDFのコピーを作成します。
- Revuでコピーを開きます。
- PDF上のマークアップを削除します(存在する場合)。マークアップを削除するには:
- マークアップリストを開きます(Alt + L)。
- マークアップリストからマークアップを選択し、Ctrl + Aを押してすべてのマークアップを選択します。
- キーボードのDeleteキーを押して、PDFからすべてのマークアップをクリアします。
- Ctrl + Sを押してコピーを保存し、ファイルを閉じます。
- [ファイル > 作成 > ファイルから]に移動します。ファイルエクスプローラウィンドウが表示されます。
- 同じコピーを選択して、[開く]をクリックします。[名前を付けて保存]ダイアログボックスが表示されます。
- [保存]をクリックします。ファイルが再作成されます。
- 元のPDFにマークアップがあった場合は、それらを再インポートする必要があります。
- [マークアップリスト > マークアップ > インポート]に移動します。ファイルエクスプローラウィンドウが表示されます。
- 元のPDFファイルを選択し、[開く]をクリックします。
これで、新しく生成されたファイルにすべてのマークアップが含まれます。
ソースファイルからPDFを生成するときは、BluebeamPDFプリンターまたはBluebeamプラグインを使用することをお勧めします。これにより、高品質のPDFが確実に作成され、ファイル固有の問題が多数発生するのを防ぐことができます。
※PDFを再作成する際にマークアップを退避させるのは、再作成によってマークアップが埋め込みになるのを避けるためです。
ご注意ください。
ご参考)
How to recreate a PDF to fix file-specific issues (bluebeam.com)